Flux RSS


Yahoo! 
MSN 
AOL 
Netvibes 
Bloglines 


Social bookmarking

Social bookmarking digg  Social bookmarking delicious  Social bookmarking reddit  Social bookmarking stumbleupon  Social bookmarking slashdot  Social bookmarking yahoo  Social bookmarking google  Social bookmarking blogmarks  Social bookmarking live      

Conservar e compartilhar o endereço de PC Seguro em seu site de social bookmarking

Conservar e compartilhar o endereço de Fórum PC Brasil em seu site de social bookmarking

Estatísticas
Temos 14523 usuários registrados
O último usuário registrado atende pelo nome de Fabio Oliveira

Os nossos membros postaram um total de 35499 mensagens em 3606 assuntos
Últimos assuntos
» Computador lento
por lucasbitt Sex 31 Jan 2020, 11:20

Quem está conectado
1 usuário online :: Nenhum usuário registrado, Nenhum Invisível e 1 Visitante :: 1 Motor de busca

Nenhum

O recorde de usuários online foi de 163 em Seg 02 Set 2019, 16:28
Buscar
 
 

Resultados por:
 


Rechercher Busca avançada

Fevereiro 2020
SegTerQuaQuiSexSabDom
     12
3456789
10111213141516
17181920212223
242526272829 

Calendário Calendário


Por favor, me ajudem com esse algoritmo, quero saber o que tem de errado nele !?

Ir em baixo

Por favor, me ajudem com esse algoritmo, quero saber o que tem de errado nele !? Empty Por favor, me ajudem com esse algoritmo, quero saber o que tem de errado nele !?

Mensagem por I93D em Sab 05 Out 2013, 16:45


1 - Elabore um algoritmo que, dados dois vetores inteiros de 20 posições, efetue as respectivas operações indicadas por outro vetor de 20 posições de caracteres também fornecido pelo usuário, contendo as quatro operações aritméticas em qualquer combinação e armazenando os resultados em um terceiro vetor.

algoritmo "semnome"
// Função :
// Autor :
// Data : 05/10/2013
// Seção de Declarações
var
v1:vetor [1..20] de inteiro
v2:vetor [1..20] de inteiro
operacao:vetor [1..20] de caracter
resposta:vetor [1..20] de real
i:inteiro
inicio
// A Entrada dos 20 primeiros valores

para i de 1 ate 20 passo 1 faca
escreval ("Digite o",i, "º valor")
leia(v1[i])
fimpara

// A entradas dos outros 20 valores

para i de 1 ate 20 passo 1 faca
escreval ("Digite o",i, "º valor")
leia(v2[i])
fimpara

// Escolha dos Operadores Aritmeticos

para i de 1 ate 20 passo 1 faca
escreval ("Escolha os operadores (+),(-), (/) e (*)")
leia (operacao[i])

escolha (operacao[i])
caso "+"
resposta[i] <-(v2 [i] - v1 [i])
escreva (resposta[i])
caso "/"
resposta[i] <-(v2 [i] / v1 [i])
escreva (resposta[i])
caso "*"
resposta[i] <-(v2 [i] * v1 [i])
escreva (resposta[i])
outrocaso
escreval ("Operador Invalido")
fimescolha
fimpara


// A saida dos calculos

para i de 1 ate 20 passo 1 faca
escreva (v1[i], " ")
fimpara

escreval ()

para i de 1 ate 20 passo 1 faca
escreva (operacao[i], " ")
fimpara

escreval ()

para i de 1 ate 20 passo 1 faca
escreva (v2[i], " ")
fimpara

escreval ()

para i de 1 ate 20 passo 1 faca
escreva (resposta[i], " ")
fimpara



fimalgoritmo
I93D
I93D
Iniciante
Iniciante

Mensagens : 5
Reputação : 0
Data de inscrição : 05/10/2013

Voltar ao Topo Ir em baixo

Por favor, me ajudem com esse algoritmo, quero saber o que tem de errado nele !? Empty Re: Por favor, me ajudem com esse algoritmo, quero saber o que tem de errado nele !?

Mensagem por MaSCaRaDe em Qui 10 Out 2013, 01:15

Olá I39D,

Vc já fez o chinês do seu código (debugar)?

Pelo que pude reparar, há um erro na operação caso "+", pois ao invés de somar, ele está subtraindo. Mas de resto, não consegui identificar nenhum problema no código.

[]s DB!
MaSCaRaDe
MaSCaRaDe
Iniciante
Iniciante

Mensagens : 2
Reputação : 0
Data de inscrição : 30/09/2013

http://www.dmbtecnologia.com.br

Voltar ao Topo Ir em baixo

Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum